Page tree
Skip to end of metadata
Go to start of metadata

Раздел Ситуационный центр предназначен для создания планов объекта для рабочих мест операторов центра мониторинга и доступен только для узла Платформа НЕЙРОСС

Полная инструкция по настройке Платформы для выполнения задач мониторинга и ситуационного реагирования приведена здесь. Руководство оператора приведено в разделе АРМ НЕЙРОСС Центр

Переход к функционалу: Рабочий стол НЕЙРОСС > Конфигурация узлов > Ситуационный центр.

 Содержание:

Формирование плана объекта

Инструменты раздела позволяют загрузить изображение плана объекта (подложку) и разместить на нём функциональные элементы для мониторинга состояния и управления посредством АРМ НЕЙРОСС Центр. Любой элемент НЕЙРОСС может быть нанесён на план в виде иконки или геометрической фигуры: отрезка, ломаной, прямоугольника, круга, произвольного многоугольника (полигона). Поддерживается иерархия планов.  Планы также являются функциональными элементами и могут быть нанесены на любой другой план. Поддерживается несколько слоёв, чтобы иметь доступ к нижележащему элементу, он должен занимать большую площадь, чем верхний.

Стандартные режимы отображения состояний элементов приведены в разделе Метки элементов НЕЙРОСС. При необходимости переопределения иконки или оформления геометрической фигуры обратитесь к инструкции в разделе Элементы.

Окно раздела

  1. Дерево планов: предоставляются инструменты управления деревом;

    КомандаИконкаКомментарий

    Создать план

    Создание нового плана верхнего уровня. Будет запрошено имя плана и файл подложки.
    Переименовать или обновить изображение плана

    Смена наименование плана, смена изображения (подложки) плана.
    Создать дочерний план

    Создание нового плана, дочернего к текущему (в строке которого вызвана команда). Планы можно переносить простым перетаскиванием.
    Копировать план

    Копирование текущего плана (в строке которого вызвана команда). На том же уровне иерархии планов будет создан идентичный план со всеми элементами, с добавкой «(копия)» и наименовании плана.
    Удалить план

    Удаление текущего плана (в строке которого вызвана команда)

    Если в домене НЕЙРОСС присутствует сетевой узел Платформа ITRIUM/ПАК Интеграция, который содержит разрешенные к выдаче в сеть НЕЙРОСС планы и функциональные элементы, планы будут автоматически добавлены в список планов вместе с размещенными на них функциональными элементами. Планы ITRIUM/ПАК Интеграция не подлежат редактированию средствами веб-интерфейса и помечены иконкой . Такой план может редактироваться только из программы «Администратор мониторинга». 

  2. Окно плана: отображается подложка выделенного в дереве планов плана с нанесёнными функциональными элементами. Индикация состояний элементов плана осуществляется с помощью иконок или цветных геометрических фигур. 

  3. Кнопки управления масштабом отображения плана и скачивания подложки;

    КомандаИконкаКомментарий

    Приблизить/отдалить

    Увеличить/уменьшить масштаб отображения на один шаг.

    Масштаб 1х1

    Отобразить план в 100% масштабе.
    Вписать в окно

    Масштабировать план таким образом, чтобы он занял наибольшую площадь окна плана.
    Скачать подложку

    Сохранить изображение плана (подложку) в папку загрузок браузера. Обратите внимание, изображение плана подвергается преобразованию в Платформе НЕЙРОСС согласно настройкам блока Обработка изображений планов [Дополнительные настройки]. Будет скачан преобразованный вариант изображения.
  4. Кнопки выбора типа отображения элемента: иконка или геометрическая фигура; предварительно необходимо выделить функциональный элемент из списка [6]; описание приведено в подразделе [Размещение элемента на плане]

  5. Команды управления положением и размером элементов плана: перемещение, поворот и прочие действия; описание приведено в разделе [Редактирование размера и положения элемента плана];

    КомандаИконкаКомментарий
  6. Список функциональных элементов: список узлов НЕЙРОСС с дочерними элементами и ONVIF-медиаисточников согласно списку из раздела Сеть.

    Разделы охранной сигнализации являются общим ресурсом, загружаются во все узлы сети, но в дереве являются дочерними элементами текущего узла Платформа НЕЙРОСС (узла, с которого выполнен вход в интерфейс). Планы и помещения также являются функциональными элементами, могут наноситься на другие планы для мониторинга и управления. При управлении планами и помещениями поддерживается их иерархия: команда управления, выполненная над планом, также передаётся и всем дочерним элементам.

    ВАЖНО

    В текущей реализации к управлению посредством элемента типа План или Помещение недоступны элементы ITRIUM. Управление такими элементами осуществляется напрямую через иконку элемента.

Для просмотра плана выберите его название в дереве планов. 

Создание плана

Создание плана включает загрузку изображения плана (подложки).

Для оптимизации нагрузки сервера на отрисовку плана, после загрузки изображения плана (подложки) производится её автоматическое сжатие. Параметры сжатия заданы в разделе Обработка изображений планов [Центр]. При необходимости, вы можете отключить автоматическую компрессию файлов.

  1. Для создания плана первого уровня, нажмите на кнопку Добавить план . Для создания плана, дочернего к выделенному в дереве элементов, нажмите на кнопку  в строке плана.
  2. В окне Создание плана введите название плана и выберите файл изображения. Поддерживаются файлы форматов PNG, JPG, JPEG.
  3. Нажмите на кнопку Сохранить.
  4. Выделите в дереве планов [1] созданный план. В окне плана [2] будет выведено изображение плана. Скроллинг в области изображения плана позволяет увеличивать/уменьшать масштаб отображения плана. Вы также можете использовать кнопки управления масштабом, расположенные в верхней части плана.
  5. Разместите на плане требуемые элементы. При необходимости, откорректируйте их размеры и расположение. Сохранение выполняется автоматически. При необходимости перемещения, изменения размеров и геометрии прямоугольных областей (в том числе вращения прямоугольников), обратитесь к инструкции в подразделе [Редактирование размера и положения элемента плана].

Если добавляете план уже работающего объекта, не забудьте добавить права на работу с планом операторам АРМ НЕЙРОСС Центр. 

Размещение элемента на плане

В дереве функциональных элементов [3] щелчком левой клавиши мыши выберите элемент. Вы можете воспользоваться окном поиска по имени, типу или IP-адресу.

ПРИМЕЧАНИЕ

Если элемент был добавлен недавно (например, — включена зона охранной сигнализации БОРЕЙ), его может не быть в списке. В этом случае нужно перевычитать конфигурацию узла БОРЕЙ в Платформу НЕЙРОСС [Выгрузка конфигурации узлов].

Начиная с версии БОРЕЙ 12996 возможен мониторинг состояний и управление реле БОРЕЙ. Необходимо выполнить обновление прошивки узла [Обновление программных средств] с последующим вычитыванием обновлённой конфигурации в Платформу НЕЙРОСС [Выгрузка конфигурации узлов].

Если требуется разместить элемент в виде иконки, то после выбора элемента просто щёлкните левой клавишей мыши в требуемом месте плана. Отобразится иконка, соответствующая типу элемента, цвет иконки будет соответствовать текущему состоянию [Элементы]. Если требуется разместить элемент в виде другой геометрической фигуры, выберите соответствующий инструмент и нанесите элемент на план. 

СОВЕТ

Для увеличения/уменьшения масштаба плана в процессе действий с элементами пользуйтесь колёсиком мыши.

Тип элементаИконкаКомментарий
Иконка

Элемент в виде иконки. В процессе размещения элемента указатель мыши принимает форму мишени. Щелчком левой клавиши мыши задайте положение иконки. Мишень точно соответствует размеру иконки.  Осуществляется «привязка» к уже размещённым элементам. 

Линия

Элемент в виде линии или ломаной. В процессе размещения элемента отображаются подсказки. Последовательно щелчком левой клавиши мыши задайте положение первой и всех последующих вершин отрезка.

Прямоугольник

Элемент в виде прямоугольника. Последовательно щелчком левой клавиши мыши задайте положение противоположных вершин прямоугольника (левой верхней / правой нижней).

Многоугольник

Элемент в виде многоугольника. Последовательно щелчком левой клавиши мыши задайте положение всех вершин многоугольника. Фигура может иметь произвольную форму, быть как выпуклым, так и невыпуклым.

Круг

Элемент в виде круга. Последовательно щелчком левой клавиши мыши задайте центр и радиус круга.

Редактирование размера и положения элемента плана

Для редактирования размера и положения элементов плана предназначены инструменты [5]. 

ИнструментИконкаКомментарий
Редактировать элементы

Позволяет путем перемещения вершин отредактировать размер и положение геометрических фигур: прямых, многоугольников, кругов. Редактирование производится путём перемещения опорной точки — вершины фигуры. Последовательно переместите опорные точки фигур. Для добавления опорной точки кликните по центру любого отрезка (выделяется меньшим по размеру кружком). Для удаления опорной точки кликните по ней правой клавишей мыши. Сохраните изменения.

Переместить элементы

Позволяет изменить положение любого элемента плана.  Последовательно переместите элементы. Для перемещения нескольких элементов группой предварительно выделите их с нажатой клавишей CTRL. Сохраните изменения.

Удалить элементы

Позволяет удалить элемент. Для удаления щелкните левой клавишей мыши в области элемента. При наведении в область элемента указатель мыши меняет вид «рука» на вид «рука с указующим пальцем». Сохраните изменения.

Повернуть элементы

Позволяет повернуть элемент прямоугольник, многоугольник, линия. Поворот производится относительно центра опорной точки — вершины геометрической фигуры. Поверните фигуру, удерживая любую опорную точку.

Выровнять элементы

Позволяет выровнять иконки элементов по горизонтали (в столбец), по вертикали (в строку). Выравнивание геометрических фигур не предусмотрено. Для выравнивания нескольких элементов, размещённых в виде иконки, предварительно выделите их с нажатой клавишей CTRL и нажмите По горизонтали или По вертикали. Выравнивание будет производится по первому выделенному элементу. Сохраните изменения.


Связать камеры с источникам тревог

Позволяет задать связь медиаисточника с источником тревог, необходимую для отображения видео по приходу тревожного события от ближайших (связанных) камер [«Привязка» камер источникам тревог].

Инструмент доступен с версии Платформы НЕЙРОСС 20.6.813.


ПОДСКАЗКА

Нажмите на кнопку  Помощь, чтобы получить справку по использованию выбранного элемента. Чтобы отменить редактирование, нажмите на кнопку Отменить. Чтобы подтвердить редактирование, нажмите на кнопку Сохранить.

Редактирование геометрических фигур: линий, прямоугольников, многоугольников, кругов

Выберите инструмент Редактировать элементы. Будут выделены вершины и центры отрезков линий всех геометрических фигур. 

  • Чтобы переместить вершину «перетащите» её с помощью drag-and-drop.
  • Чтобы добавить вершину, нажмите в центре отрезка линии.
  • Чтобы удалить вершину, нажмите на ней правой клавишей мыши.

По окончании нажмите на кнопку Сохранить.


Перемещение элементов

Выберите инструмент  Переместить элементы. С помощью drag-and-drop последовательно переместите элементы. Для перемещения нескольких элементов группой предварительно выделите элементы щелчком левой клавиши мыши в его области с нажатой клавишей CTRL клавиатуры. По окончании нажмите на кнопку Сохранить.


Удаление элементов

Выберите инструмент  Удалить элементы. Нажмите на область/элемент, который необходимо удалить. Если необходимо удалить несколько элементов, последовательно щёлкните несколько элементов. По окончании нажмите на кнопку Сохранить.


Поворот фигур

Выберите инструмент  Повернуть элементы. Наведите указатель мыши на вершину, относительно которой нужно повернуть фигуру. С помощью drag-and-drop поверните фигуру. По окончании нажмите на кнопку Сохранить.


Выравнивание иконок

Выберите инструмент  Выровнять элементы. Выделите элементы щелчком левой клавиши мыши в его области с нажатой клавишей CTRL клавиатуры. Первым выделите элемент, по которому требуется осуществить выравнивание. Нажмите на кнопку По горизонтали для выравнивания влево/вправо до положения «в столбец». Нажмите на кнопку По вертикали для выравнивания вверх/вниз до положения «в строку». По окончании нажмите на кнопку Сохранить.

Смена изображения плана

Вы можете в любой момент времени поменять подложку для плана. Если файл изображения потерян, вы можете скачать загруженный ранее файл и отредактировать его.

Скачать изображение плана:

  1. Нажмите на кнопку  Сохранить изображение плана на локальный компьютер [3].
  2. Файл изображения будет сохранён в папке загрузок браузера. Так как изображение плана подвергается преобразованию в Платформе НЕЙРОСС согласно настройкам блока Обработка изображений планов [Дополнительные настройки], иформация о формате файла изображения будет потеряна. Файл не будет иметь расширение. Однако большинство современных редакторов изображений умеют самостоятельно распознавать формат файла. В противном случае вы всегда можете присвоить расширение вручную, последовательно попробовав форматы PNG, JPG, JPEG.

  3. С помощью любого графического редактора внесите изменения в изображение и загрузите обновлённый файл согласно инструкции ниже.

Загрузить изображение плана:

  1. В дереве планов [1] нажмите на кнопку  Переименовать или обновить изображение плана, расположенную в строке требуемого плана.
  2. В окне редактирования плана укажите путь к обновленному файлу, нажмите на кнопку Сохранить.

Поддержка предыдущих версий

В версии Платформы НЕЙРОСС до 20.5 представлен больше узкий перечень элементов для нанесения на план.

 Раскрыть | Инструменты предыдущих версий Платформы НЕЙРОСС

В предыдущих версиях Платформы НЕЙРОСС элемент может быть нанесён на план в виде иконки, произвольного многоугольника, прямоугольника или круга. 

Нанесение элемента

1. Если требуется разместить элемент в виде иконки, просто щёлкните левой клавишей мыши в требуемом месте плана. 

2. Если требуется разместить элемент в виде многоугольника, выберите инструмент  Отметить произвольную область. Щелчком мыши последовательно укажите все вершины фигуры. Для замыкания фигуры, щелкните в область первой вершины. Цвет области отобразит текущее состояние элемента. 

3. Если требуется разместить элемент в виде прямоугольника или круга, выберите инструмент  Отметить прямоугольную область или  Отметить круг

Предоставляется возможность редактировать положение и размер элементов плана.

Редактирование размера и положения элемента плана

Нажмите на кнопку Редактировать элементы. Будут выделены границы всех элементов плана.

Наведите указатель мыши на требуемый элемент/область и используйте drag-and-drop «хватай и тащи». 
Вы можете:

  • Переместить точечный элемент.
  • Переместить вершину прямоугольной области, щелчком левой клавиши мыши добавить новую вершину на середине сегмента произвольной области и переместить её.
  • Переместить, повернуть прямоугольник или изменить его размеры.
  • Переместить круг и изменить его размеры.
  • По окончании редактирования нажмите на кнопку Сохранить для сохранения изменений или Отмена для возврата к предыдущему состоянию плана.

Удаление элемента плана

  1. Нажмите на кнопку Удалить элементы .
  2. Нажмите на область/элемент, который необходимо удалить. Если необходимо удалить несколько элементов, последовательно щёлкните несколько элементов.
  3. Нажмите на кнопку Сохранить для подтверждения удаления, Отмена для возврата к предыдущему состоянию или Удалить все для очистки плана от всех элементов.

Кластеризация иконок

При масштабировании плана в сторону его уменьшения во избежание «наложения» несколько рядом расположенных иконок друг на друга в АРМ НЕЙРОСС Центр обеспечивается кластеризация иконок. Цвет кластера указывает на наличие/отсутствие в нём элементов в состояниях тревоги/неисправности, цифра указывает на количество элементов в кластере: 

При помощи кнопок переключения возможно отключать/включать режим кластеризации в АРМ НЕЙРОСС Центр на конкретном АРМ.

Размещение элементов на карте

Средства вкладки Карта позволяют указать географическое положение функционального элемента — узла НЕЙРОСС. Для каждого элемента можно зарезервировать область или точку на плане. При возникновении тревоги данная информация поможет оператору сориентироваться на местности.

Окно вкладки содержит список доступных к нанесению функциональных элементов, саму карту и требуемые инструменты.

Добавление элемента на карту

  1. В списке слева выберите функциональный элемент. Вы можете воспользоваться окном поиска по имени, типу или IP-адресу.
  2. Если требуется разместить элемент в виде иконки, просто щёлкните левой клавишей мыши в требуемом месте плана. После размещения отобразится иконка, соответствующая типу элемента. Цвет иконки будет соответствовать текущему состоянию.
  3. Если требуется разместить элемент в виде геометрической фигуры, выберите соответствующий инструмент и разместите элемент на карте. Действия аналогичны размещению элементов на плане [Размещение элемента на плане]. Цвет области отобразит текущее состояние элемента. 
  4. Нажмите на кнопку Сохранить.

Редактирование положения и размера элемента карты

  1. Нажмите на кнопку редактирования области . Будут выделены границы всех областей.
  2. Наведите указатель мыши на требуемую область. Посредством drag-and-drop «хватай и тащи» вы можете переместить точечный элемент или перетащить/изменить размеры геометрической фигуры.
  3. По окончании редактирования нажмите на кнопку Сохранить для сохранения изменений или Отменить для возврата к предыдущему расположению.

Удаление, поворот и выравнивание элементов карты также осуществляется аналогично действиям над элементами плана [Редактирование размера и положения элемента плана].

Настройка схемы обработки инцидентов

Вкладка Обработка инцидентов предоставляет инструмент загрузки xml-схемы обработки.

Предустановлена стандартная схема обработки: оператор принимает инцидент в обработку, самостоятельно изучает состояния и события элементов, просматривает «живое» видео и видеоархив, формирует фото- и видеоматериалы, выполняет управляющие команды, формирует текстовый комментарий к инциденту и завершает его обработку. При необходимости использования более сложного сценария обработки (с разветвлением и инструкциями оператору по шагам обработки) возможен заказ такой разработки [Лицензирование | Платформа НЕЙРОСС].

События могут быть отфильтрованы по типам, источникам и проч., позволяя дифференцировать алгоритмы обработки разных событий. Задачи, которые чаще всего требуется выполнять оператору, могут быть частично или полностью автоматизированы. Например, события технической неисправности могут автоматически адресоваться службе эксплуатации. 

Предустановлен стандартный алгоритм обработки. Вы можете оформить заявку на разработку нестандартного многошагового алгоритма с контролем действий оператора.

  1. Нажмите на кнопку  для добавления нового алгоритма.
  2. В окне создания алгоритма введите название алгоритма, в поле Фильтр по событиям из раскрывающегося списка выберите созданный ранее фильтр или нажмите [Настроить фильтры] для перехода к созданию нового фильтра [Фильтры]. Нажмите на кнопку Добавить и начать редактировать.

    Фильтр событий позволяет разделить все входящие события на несколько потоков и для каждого потока в отдельности задать свой алгоритм обработки. Фильтры настраиваются в разделе Фильтры. Для перехода к разделу вы также можете воспользоваться кнопкой Настроить фильтры .

  3. В поле Описание схемы нажмите на кнопку Выбрать файл и укажите файл XML-описания алгоритма обработки или перейдите к вкладке Редактирование и вставьте текстовый код алгоритма в формате XML-документа. Нажмите на кнопку Сохранить.


    Пример схемы с автоматическим формированием фотоматериалов и выгрузкой отчёта в формате PDF

    Пример сложной разветвлённой схемы обработки инцидентов АвтоКПП

  4. На вкладках Текущая схема и Редактирование вы можете просмотреть алгоритм в графическом или текстовом виде соответственно. 

    Вы можете заказать разработку XML-описания алгоритма обработки у компании-производителя. Для работы в режиме PSIM (обработки события по алгоритму), требуется приобретение соответствующей лицензии.

«Привязка» камер источникам тревог

Инструменты вкладки Источники тревог позволяет задать для каждого источника так называемые «связанные медиаисточники». В процессе обработки события для уточнения характера инцидента оператору будет предложено просмотреть видеоматериалы от выбранных медиаисточников (камер). Также данная связь используется для формирования тревожного монитора системы видеонаблюдения [Тревожный монитор].

  1. В списке Источники тревог выберите источник, который будет инициировать событие, требующее обработки. Например, точку доступа.
  2. В списке медиаисточников, отображающихся в окне справа, выберите требуемые камеры.
  3. Нажмите на кнопку Сохранить.

В версии Платформы НЕЙРОСС, начиная с 20.6.813 реализован графический интерфейс «связывания» элемента - источника тревог с медиаисточниками. 

Для этого в режиме редактирования планов или карты выберите инструмент  Связать камеры с источникам тревог. Все элементы начнут отображаться в черно-белой гамме. Щелчком левой клавиши мыши выделите элемент — источник тревоги. Затем наведите указатель мыши на элемент камеры видеонаблюдения, щелкните левой клавишей мыши для создания связи. Повторите действие для других камер. Для отмены связи наведите указатель мыши на элемент камеры и повторно нажмите на левую клавишу мыши. После создания связей для выбранного источника нажмите на кнопку Сохранить. Повторите для других источников тревог.

 

Элемент может быть представлен не только иконкой, но и геометрической фигурой.


  • No labels